dist-upgrade ging schief – unerfüllte Abhängigkeiten

Hallo,

Hoffe dies ist der richtige Bereich um das zu posten.

Ich habe heute ein dist-upgrade zu jessie zu stretch (Debian) durchführen wollen, leider ist es bei der hälfte abgebrochen und gibt mir nun folgende Fehlermeldungen:

Code:

root@knickscraft:~# apt-get dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 python3 : Hängt ab von: python3-minimal (= 3.4.2-2) aber 3.5.3-1 ist installiert
 python3-apt : Hängt ab von: python3 (>= 3.5~) aber 3.4.2-2 ist installiert
 python3-dbus : Hängt ab von: python3 (>= 3.5~) aber 3.4.2-2 ist installiert
                Hängt ab von: libdbus-1-3 (>= 1.9.14) aber 1.8.22-0+deb8u1 ist installiert
 python3-gi : Hängt ab von: python3 (>= 3.5~) aber 3.4.2-2 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets


Bei "apt –fix-broken install" gibt es folgende Fehlermeldung:

Code:

root@knickscraft:~# apt --fix-broken install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libarchive-extract-perl libasprintf0c2 libboost-iostreams1.55.0 libcpan-meta-perl libdata-section-perl libenca0 liblog-message-perl liblog-message-simple-perl libmodplug1 libmodule-build-perl libmodule-pluggable-perl
  libmodule-signature-perl libpackage-constants-perl libperl4-corelibs-perl libpgm-5.1-0 libpod-latex-perl libpod-readme-perl libregexp-common-perl libsoftware-license-perl libtask-weaken-perl libterm-ui-perl libtext-soundex-perl
  libtext-template-perl libuuid-perl libx265-87 libzmq3 python-gdbm python-support
Verwenden Sie »apt autoremove«, um sie zu entfernen.
The following additional packages will be installed:
  dbus libapparmor1 libdbus-1-3 libpython3-stdlib python3
Vorgeschlagene Pakete:
  default-dbus-session-bus | dbus-session-bus python3-doc python3-tk python3-venv
Die folgenden NEUEN Pakete werden installiert:
  libapparmor1
Die folgenden Pakete werden aktualisiert (Upgrade):
  dbus libdbus-1-3 libpython3-stdlib python3
4 aktualisiert, 1 neu installiert, 0 zu entfernen und 167 nicht aktualisiert.
6 nicht vollständig installiert oder entfernt.
Es müssen 519 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 97,3 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] y
Holen:1 http://ftp.de.debian.org/debian stretch/main amd64 python3 amd64 3.5.3-1 [21,6 kB]
Holen:2 http://ftp.de.debian.org/debian stretch/main amd64 libpython3-stdlib amd64 3.5.3-1 [18,6 kB]
Holen:3 http://ftp.de.debian.org/debian stretch/main amd64 libapparmor1 amd64 2.11.0-3 [78,7 kB]
Holen:4 http://ftp.de.debian.org/debian stretch/main amd64 dbus amd64 1.10.18-1 [208 kB]
Holen:5 http://ftp.de.debian.org/debian stretch/main amd64 libdbus-1-3 amd64 1.10.18-1 [192 kB]
Es wurden 519 kB in 0 s geholt (3.926 kB/s).
python3.5-minimal (3.5.3-1) wird eingerichtet ...
Traceback (most recent call last):
  File "/usr/lib/python3.5/py_compile.py", line 6, in <module>
    import importlib._bootstrap_external
  File "/usr/lib/python3.5/importlib/__init__.py", line 57, in <module>
    import types
  File "/usr/lib/python3.5/types.py", line 166, in <module>
    import functools as _functools
  File "/usr/lib/python3.5/functools.py", line 23, in <module>
    from weakref import WeakKeyDictionary
  File "/usr/lib/python3.5/weakref.py", line 12, in <module>
    from _weakref import (
ImportError: cannot import name '_remove_dead_weakref'
dpkg: Fehler beim Bearbeiten des Paketes python3.5-minimal (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python3-minimal:
 python3-minimal hängt ab von python3.5-minimal (>= 3.5.3-1~); aber:
  Paket python3.5-minimal ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes python3-minimal (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 python3.5-minimal
 python3-minimal
E: Sub-process /usr/bin/dpkg returned an error code (1)


Hoffe es kann mir jemand bei diesem Problem helfen. Eine Schritt für Schritt Anleitung währe hilfreich, da ich mich selbst nicht als Profi in diesem Bereich sehe.

,
crysis992

Related Post

Leave a Reply

Your email address will not be published. Required fields are marked *